Thank you!


Our team is very happy that you chose to download our mod. We have been working on it for years for nothing but love for the Age of Empires series. Before installing, please make sure you have the requirements:

1. System Requirements

  • OS: Windows XP
  • Processor: Intel Core 2 Duo 2.2 GHz or AMD Athlon 64 X2 2.0 GHz
  • Memory: 2 GB RAM
  • Graphics: 64 MB NVIDIA GeForce 6800 or ATI Radeon X1300
  • DirectX®: dx90c
  • Hard Drive: 20 GB HD space

2. Game Requirements

  • Age of Empires® III: Complete Collection
  • OR
  • Age of Empires® III +
  • Age of Empires® III: The Warchiefs +
  • Age of Empires® III: The Asian Dynasties
  • All three are required to play.

3. Software Requirements

  • The game MUST be updated to 1.03 in order to play.
  • Make sure you don't have any other mod installed, not even a previous version of this mod.

4. Download the installer

  • The installer can be found in our forum. Click here.
  • Wars of Liberty installs itself, no worries.

5. Updates

  • Make sure you have downloaded the Updater. Click here.
  • Wars of Liberty updates itself every time you open the Updater.

...and that's all! Enjoy Wars of Liberty.



Curiosities

You can contact the team by joining our forums or by sending a mail here. We understand English, Spanish, Portuguese, Greek, Dutch, French and German (whew!). But we prefer English whenever possible.

Support Us

Monument

You can support us to maintain this site by donating. Click here to find out how.