A free fan-made modification for Age of Empires III

 
User avatar
danielpereira
Rum Corpsman
Rum Corpsman
Posts: 163
Joined: Tue Jul 26, 2016 11:37 am
Location: The Republic of São Paulo
Contact:

Re: Installation errors

Tue Sep 13, 2016 5:24 pm

Dark_Yodada wrote:
Aaaaaaand of course that game doesn't want to be played, now the error message is : Failed to load required library wol.dll...

Are you sure that you have updated WoL to the latest patch using the updater? The need for a wol.dll has been eliminated in 1.0.6 and 1.0.7....
Image
 
Dark_Yodada
Idle Settler
Idle Settler
Posts: 10
Joined: Thu Sep 08, 2016 5:09 pm

Re: Installation errors

Wed Sep 14, 2016 1:51 pm

The uptade fail on installing 2/5 :

Current Wars of Liberty Installation:
C:\Program Files (x86)\Microsoft Games\Age of Empires III

Fetching update info file...

Wars of Liberty version 1.0.3 detected

Downloading update #1 of 4 (5,93 MB)
Finished downloading update #1 of 4
Installing update #1 of 4
An error has occurred while attempting to perform
that operation

java.io.FileNotFoundException: C:\Program Files (x86)\Microsoft Games\Age of Empires III\data\abilities\abilityfire.xml (Accès refusé)
java.io.FileOutputStream.open0(Native Method)
java.io.FileOutputStream.open(Unknown Source)
java.io.FileOutputStream.<init>(Unknown Source)
java.io.FileOutputStream.<init>(Unknown Source)
wolUpdater.Updater.extractUpdate(Updater.java:333)
wolUpdater.Updater.downloadInstallUpdates(Updater.java:291)
wolUpdater.Updater.main(Updater.java:100)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
java.lang.reflect.Method.invoke(Unknown Source)
org.eclipse.jdt.internal.jarinjarloader.JarRsrcLoader.main(JarRsrcLoader.java:58)
 
User avatar
danielpereira
Rum Corpsman
Rum Corpsman
Posts: 163
Joined: Tue Jul 26, 2016 11:37 am
Location: The Republic of São Paulo
Contact:

Re: Installation errors

Wed Sep 14, 2016 3:15 pm

Oh well, if you are getting this error, then that means that, for some reason, the updater isn't allowed to change that particular file...

Are you running the updater as admin? Also, are you sure you are running the updater with the game closed?

If you can't get the updater to work, you could try downloading the manual install.
Image
 
Dark_Yodada
Idle Settler
Idle Settler
Posts: 10
Joined: Thu Sep 08, 2016 5:09 pm

Re: Installation errors

Wed Sep 14, 2016 3:50 pm

Yes I am running the uptader as an admin and my game is closed...
I absolutely don't know how to download it manually, could you help me some more please ? :)
 
User avatar
danielpereira
Rum Corpsman
Rum Corpsman
Posts: 163
Joined: Tue Jul 26, 2016 11:37 am
Location: The Republic of São Paulo
Contact:

Re: Installation errors

Thu Sep 15, 2016 3:33 am

Dark_Yodada wrote:
Yes I am running the uptader as an admin and my game is closed...
I absolutely don't know how to download it manually, could you help me some more please ? :)

The links for the manual download of the patches are in the first post of the Updater thread ^^
viewtopic.php?f=2&t=19
Image
 
Dark_Yodada
Idle Settler
Idle Settler
Posts: 10
Joined: Thu Sep 08, 2016 5:09 pm

Re: Installation errors

Thu Sep 15, 2016 3:05 pm

What a surprise !!! I extracted the uptade 1.0.7 in the AOE III folder aaaand it's not working... Always that wol.dll
I think my computer doesn't want me to play that game...

Yes, I runned the 107_postuptade.bat.
 
User avatar
danielpereira
Rum Corpsman
Rum Corpsman
Posts: 163
Joined: Tue Jul 26, 2016 11:37 am
Location: The Republic of São Paulo
Contact:

Re: Installation errors

Thu Sep 15, 2016 3:50 pm

Dark_Yodada wrote:
What a surprise !!! I extracted the uptade 1.0.7 in the AOE III folder aaaand it's not working... Always that wol.dll
I think my computer doesn't want me to play that game...

Yes, I runned the 107_postuptade.bat.

Are you sure you have downloaded both 1.0.6 and 1.0.7 and extracted in the folder in which you installed WoL? 1.0.6 is also needed, you were supposed to extract 1.0.6 first and then extract 1.0.7.
Image
 
Dark_Yodada
Idle Settler
Idle Settler
Posts: 10
Joined: Thu Sep 08, 2016 5:09 pm

Re: Installation errors

Thu Sep 15, 2016 4:34 pm

Ok so as I am not a good informatician I installed the 1.0.7 only.
So I uninstalled once more Wars of Liberty and I reinstalled it. I extracted the two uptades in order. I runned 107_postuptade.bat.
And the DATAPY.BAR is back. :(
 
User avatar
danielpereira
Rum Corpsman
Rum Corpsman
Posts: 163
Joined: Tue Jul 26, 2016 11:37 am
Location: The Republic of São Paulo
Contact:

Re: Installation errors

Thu Sep 15, 2016 5:28 pm

Are you sure you have installed WoL in a folder that contains a valid AoE3 installation? If so, could you try to run WoL directly (that is, run the age3y.exe from the folder in which you installed WoL, without using any shortcuts or launchers)?
Image
 
Dark_Yodada
Idle Settler
Idle Settler
Posts: 10
Joined: Thu Sep 08, 2016 5:09 pm

Re: Installation errors

Fri Sep 16, 2016 3:52 pm

Yes my AOE is perfectly working (but not when I have Wars of Liberty installed I think it's normal).
And I tried lauching the age3y.exe and same error : Could not load DATAPY.BAR

Who is online

Users browsing this forum: No registered users and 1 guest